a.h.s.d

مشکل در اجرای متاسپلویت

7 ارسال در این موضوع قرار دارد

دوستان من کالی لینوکس 32 بیتی رو تازه نصب کردم متاسپلویت پیش فرض روش نصبه وقتی بازش میکنم با ارور زیر مواجه میشم و برمیگردونه به روت

مشکل از چیه و چیکار باید بکنم؟

A database appears to be already configured, skipping initialization
/usr/share/metasploit-framework/lib/msf/core/payload/android.rb:92:in `not_after=': bignum too big to convert into `long' (RangeError)
    from /usr/share/metasploit-framework/lib/msf/core/payload/android.rb:92:in `sign_jar'
    from /usr/share/metasploit-framework/lib/msf/core/payload/android.rb:123:in `generate_jar'
    from /usr/share/metasploit-framework/modules/payloads/singles/android/meterpreter_reverse_tcp.rb:44:in `generate_jar'
    from /usr/share/metasploit-framework/lib/msf/core/payload/android.rb:38:in `generate'
    from /usr/share/metasploit-framework/lib/msf/core/payload.rb:204:in `size'
    from /usr/share/metasploit-framework/lib/msf/core/payload_set.rb:91:in `block in recalculate'
    from /usr/share/metasploit-framework/lib/msf/core/payload_set.rb:78:in `each_pair'
    from /usr/share/metasploit-framework/lib/msf/core/payload_set.rb:78:in `recalculate'
    from /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:251:in `block in load_modules'
    from /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:248:in `each'
    from /usr/share/metasploit-framework/lib/msf/core/modules/loader/base.rb:248:in `load_modules'
    from /usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:119:in `block in load_modules'
    from /usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:117:in `each'
    from /usr/share/metasploit-framework/lib/msf/core/module_manager/loading.rb:117:in `load_modules'
    from /usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:41:in `block in add_module_path'
    from /usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:40:in `each'
    from /usr/share/metasploit-framework/lib/msf/core/module_manager/module_paths.rb:40:in `add_module_path'
    from /usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:50:in `block in init_module_paths'
    from /usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:49:in `each'
    from /usr/share/metasploit-framework/lib/msf/base/simple/framework/module_paths.rb:49:in `init_module_paths'
    from /usr/share/metasploit-framework/lib/msf/ui/console/driver.rb:196:in `initialize'
    from /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:62:in `new'
    from /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:62:in `driver'
    from /usr/share/metasploit-framework/lib/metasploit/framework/command/console.rb:48:in `start'
    from /usr/share/metasploit-framework/lib/metasploit/framework/command/base.rb:82:in `start'
    from /usr/bin/msfconsole:48:in `<main>'
root@kali:~# 
 

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

سلام متاسپلویت به خوبی نصب نشده است کالی را یک بار حذف و دوباره نصب کنید یا اینکه متاسپلویت را کاملا حذف و دوباره نصب کنید

آموزش حذف و نصب متاسپلویت نیز در اینترنت موجود است

اگر این مشکلتان را حل نکرد 

ارور خود را در سایت github مطرح بفرمایید 

موفق باشید💙

 

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
در 3 ساعت قبل، armanbabaei گفته است :

سلام متاسپلویت به خوبی نصب نشده است کالی را یک بار حذف و دوباره نصب کنید یا اینکه متاسپلویت را کاملا حذف و دوباره نصب کنید

آموزش حذف و نصب متاسپلویت نیز در اینترنت موجود است

اگر این مشکلتان را حل نکرد 

ارور خود را در سایت github مطرح بفرمایید 

موفق باشید💙

 

کالی رو حذف کردم دوباره نصب کردم جواب نداد متاسفانه

ارورش رو قبلا یکی داخل گیتهاب گذاشته اما اونارو هم خوندم جواب درستی نگرفتم 
بنظرتون ممکنه این نسخه کالی که من دارم ناقص باشه یا پکیج های پیش نیاز برای متاسپلویت رو نداشته باشه؟ یا بخاطر نصب کالی داخل ماشین مجازی باشه؟

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

ببینید دوست گرامی این اروری که من دیدم فکر کنم بیشتر مربوط به اسکریپت های متاسپلویت باشه 

میتونید با دستور زیر متاسپلویت رو آپدیت بکنید شاید حل  بشه

msfupdate

 

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

با سلام

یعنی هرکسی تو لینوکس مشکل داشت باید بیخیال اواس بشه واز نو نصیب کنه عجب اینم جوک ساله عایا

دوست عزیز شما این چنتا کارو انجام بدید فک کنم مشکلتون درست بشه

sudo apt-get update

sudo apt-get install metasploit-framework
یا
msfdb delete
msfdb init
cp /usr/share/metasploit-framework/config/database.yml /root/.msf4/
sudo service postgresql restart
sudo msfconsole
msf > db_status
[*] postgresql connected to msf
msf >

ویا 
 apt-get install -y metasploit-framework

 

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
در 1 ساعت قبل، 0r0b4s گفته است :

با سلام

یعنی هرکسی تو لینوکس مشکل داشت باید بیخیال اواس بشه واز نو نصیب کنه عجب اینم جوک ساله عایا

دوست عزیز شما این چنتا کارو انجام بدید فک کنم مشکلتون درست بشه


sudo apt-get update

sudo apt-get install metasploit-framework
یا
msfdb delete
msfdb init
cp /usr/share/metasploit-framework/config/database.yml /root/.msf4/
sudo service postgresql restart
sudo msfconsole
msf > db_status
[*] postgresql connected to msf
msf >

ویا 
 apt-get install -y metasploit-framework

 

با دستور اخر درست شد خیلی ممنون لطف کردید 

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
در 2 ساعت قبل، armanbabaei گفته است :

ببینید دوست گرامی این اروری که من دیدم فکر کنم بیشتر مربوط به اسکریپت های متاسپلویت باشه 

میتونید با دستور زیر متاسپلویت رو آپدیت بکنید شاید حل  بشه


msfupdate

 

و همچنین ممنون از شما که نظر دادید

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

برای ارسال دیدگاه یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید دیدگاهی ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در سایت ما ثبت نام کنید. عضویت خیلی ساده است !

ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید

ورود به حساب کاربری