رفتن به مطلب

مشکل پایتون در کالی لینوکس.


ارسال های توصیه شده

سلام دوستان.من خیلی وقته این مشکل رو دارم.

من این چند روزه چندتا ابزار پایتونی  نصب کردم که وقتی میخوام اجراش کنم ارور ماژول میده درصورتی که کتابخانه ها نصب شده و داخل پروژه ایمپورت هم شده و توی برخی ابزار ها مدام ارور های مسخره از کتابخانه ها میگیره !

من هیچکدام از این مشکلات رو روی ویندوز ندارم ولی تا نوبت کالی لینوکس میشه و میخوام اسکریپت هارو ران کنم روی ترمینال میگه ماژول پیدا نشد در صورتی که نصبه و درست ایمپورت شده😐

لطفا لطفا کمکم کنین و راهی برای رفع این ارور های عجیبی که میده بدید. خیلی به اون ابزار ها نیاز دارم ولی کار نمیکنه و ارور های ماژول و ایمپورت و از اینجور چیزا میده.

ممنون میشم کمکم کنید با تشکر خدانگهدار.

لینک به دیدگاه
به اشتراک گذاری در سایت های دیگر

  • مدیر کل

دوست عزیز عکس آپلود کن اگه میخوای مشکلت حل بشه

و اینکه چطوری کتابخونه ها رو نصب کردی؟

لینک به دیدگاه
به اشتراک گذاری در سایت های دیگر

1764209596_Screenshot2022-10-22144249.png.b31b940bfa2b8344c3e2239814b6afdd.png

1096804510_Screenshot2022-10-22144324.png.96e32576dd4d40df4f0a105e70699757.png

636135928_Screenshot2022-10-22144419.png.2910c200f30a3ce83361c2014c44c815.png

 

سلام.

 

این ها یک نمونه برای کتابخانه requests هستن.

و من با دستور pip install کتابخانه هارو دانلود میکنم.

 

درضمن فقط این ابزار و کتابخانه requests نیست من اکثر ابزار هارو با vs code ران میکنم چون تو ترمینال نمیاد ولی برخی ابزار ها توی هیچکدوم نمیاد.

کتابخانه urllib3 هم شدیدا این مشکل رو داره و حتی تو Vs code هم ایمپورت نمیشه. ولی نصب شده:

 

 

12344556.png.08a77d0ca7542c5179f275dbdc29ceae.png

 

مشکل من این هست. 

لینک به دیدگاه
به اشتراک گذاری در سایت های دیگر

  • نخبه

سلام

احتمالا توی vscode نرفتین interpreter درست رو ست کنید. Ctrl + Shift + P رو بگیرید و بنویسید python select interpreter و انتخابش کنید. اونجا ورژن پایتونی که در سیستم ازش استفاده می کنید رو انتخاب کنید تا pylance کتابخونه هارو از روی اون بخونه و موقع اجرای کد هم از همون interpreter استفاده کنه.

لینک به دیدگاه
به اشتراک گذاری در سایت های دیگر

سلام. این کار رو خیلی وقته انجام دادم.توی vs code درسته ولی توی ترمینال با اینکه درستش کردم کار نمیکنه خیلی تحقیق کردم به جوابی نرسیدم متاسفانه😔

لینک به دیدگاه
به اشتراک گذاری در سایت های دیگر

  • نخبه

خب از alias استفاده کنید و python3 رو ست کنید روی اون ورژنی توی vscode هم استفاده میشه.

اصولا دیگه نباید مشکلی باشه.

لینک به دیدگاه
به اشتراک گذاری در سایت های دیگر

سلام.

ممنون از همه مشکلم حل شد فقط میبایست به جای python3 بزنم python برای برخی ابزار ها که با پایتون3 نیستن

لینک به دیدگاه
به اشتراک گذاری در سایت های دیگر

برای ارسال دیدگاه یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید دیدگاهی ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در سایت ما ثبت نام کنید. عضویت خیلی ساده است !

ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید

ورود به حساب کاربری
 اشتراک گذاری

انجمن تیم امنیتی گارد ایران

تیم امنیتی گارد ایران یک گروه مستقل است که قوانین آن با خط مشی جمهوری اسلامی ایران مغایرت ندارد. تیم امنیتی گارد ایران از سال 1393 فعالیت خود را آغاز کرد و هدف این تیم تامین امنیت سایت ها و سرورهای ایرانی است. تیم ما همیشه برای دفاع از مرزهای سایبری سرزمین عزیزمان ایران آماده است.

شرکت گاردایران

پردازشگران ایمن داده ي آدلان

شماره ثبت: 9438

شبکه های اجتماعی

 

نمادها

logo.aspx?id=56084&Code=ybjZVyBlXag5cNRv logo-samandehi

×
×
  • اضافه کردن...

اطلاعات مهم

فعالیت شما در این انجمن به منزله تایید قوانین انجمن میباشد! شرایط استفاده