ts icon
سرور تیم اسپیک گاردایران
amii1376

مشکل در نصب ابزار hcxtools

پست های پیشنهاد شده

سلام 

 

  در هنگام نصب ابزار hcxtools با دستور: 

 

cc -O3 -Wall -Wextra -std=gnu99  -MMD -MF .deps/hcxpcapngtool.d -o hcxpcapngtool hcxpcapngtool.c -lz -lcrypto

 

خطای زیر رو دریافت میکنم :
 

 


hcxpcapngtool.c:18:10: fatal error: openssl/sha.h: No such file or directory


   18 | #include <openssl/sha.h>
      |          ^~~~~~~~~~~~~~~
compilation terminated.
make: *** [Makefile:86: hcxpcapngtool] Error 1

 

تصویر خطا :

 

Capture.PNG

 

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

درود کاربر گرامی

 

* نکته

قبل از ارسال پست ، قوانین انجمن رو مطالعه کنید که این قوانین شما رو مجاب میکنه تا به زبان فارسی تایپ کنید

فارسی تایپ کردن شما باعث میشه این مطلب در گوگل درست ایندکس بشه تا دیگر اشخاصی که به این مسئله بر میخورند به راحتی تاپیک رو پیدا کنند و از راه حل موجود استفاده کنند

+ پست شما ویرایش شد

 

* راه حل

موردی که موجب ایجاد این خطا میشه نبود Dependency مربوطه (OpenSSL) در سیستم شما هست

حتما قبل از نصب و استفاده از یک ابزار ، فایل README اون رو در مخازن گیت مربوطه مطالعه کنید

 

لیست منابع مورد نیاز بر اساس مخزن رسمی گیت هاب این ابزار :

 

Linux (recommended Arch Linux, but other distros should work, too (no support for other distributions).

libopenssl and openssl-dev installed

librt and librt-dev installed (should be installed by default)

zlib and zlib-dev installed (for gzip compressed cap/pcap/pcapng files)

libcurl and curl-dev installed (used by whoismac and wlancap2wpasec)

libpthread and pthread-dev installed (used by hcxhashcattool)

 

دستور نصب تمامی منابع مربوطه در کالی لینوکس :

 

apt-get install libcurl4-openssl-dev libssl-dev zlib1g-dev

 

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر
در 17 ساعت قبل، R3dC0d3r گفته است :

درود کاربر گرامی

 

* نکته

قبل از ارسال پست ، قوانین انجمن رو مطالعه کنید که این قوانین شما رو مجاب میکنه تا به زبان فارسی تایپ کنید

فارسی تایپ کردن شما باعث میشه این مطلب در گوگل درست ایندکس بشه تا دیگر اشخاصی که به این مسئله بر میخورند به راحتی تاپیک رو پیدا کنند و از راه حل موجود استفاده کنند

+ پست شما ویرایش شد

 

* راه حل

موردی که موجب ایجاد این خطا میشه نبود Dependency مربوطه (OpenSSL) در سیستم شما هست

حتما قبل از نصب و استفاده از یک ابزار ، فایل README اون رو در مخازن گیت مربوطه مطالعه کنید

 

لیست منابع مورد نیاز بر اساس مخزن رسمی گیت هاب این ابزار :

 


Linux (recommended Arch Linux, but other distros should work, too (no support for other distributions).

libopenssl and openssl-dev installed

librt and librt-dev installed (should be installed by default)

zlib and zlib-dev installed (for gzip compressed cap/pcap/pcapng files)

libcurl and curl-dev installed (used by whoismac and wlancap2wpasec)

libpthread and pthread-dev installed (used by hcxhashcattool)

 

دستور نصب تمامی منابع مربوطه در کالی لینوکس :

 


apt-get install libcurl4-openssl-dev libssl-dev zlib1g-dev

 

ممنون چشم بعد این رعایت می کنم 

فقط این مخازن به مخزن کالی یعنی sources.list اضافه می کنم ؟؟؟ 

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

خیر !

 

دستور بالا ابزار Advance Package Tool در لینوکس رو صدا میزنه که پکیج های مربوطه رو نصب کنه ؛

 

و باید در خط فرمان (ترمینال) نوشته بشه .

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

برای ارسال دیدگاه یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید دیدگاهی ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در سایت ما ثبت نام کنید. عضویت خیلی ساده است !

ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید

ورود به حساب کاربری